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About this document

This document is intended as a guide for installation, maintenance and troubleshooting 
of Portable Device Manager (WinPDM) and is relevant for:

• Installation and parameter setup

• Device administration and WinPDM daily use

The WinPDM provides a generic application for managing all devices (e.g. handsets 
and chargers) on one or more sites. The WinPDM makes it possible to edit parameters, 
update software in the devices and upload files. It can save parameters and software 
for individual sites in a database.

Cross-references in the document

Throughout this document you will find cross-references in the text which indicate 
further details that can be found in other sections of this document. The cross-
references are colored blue and linked to the relevant place in the document (example: 
see chapter 9. Document History on page 44). Positioning your cursor over the cross-
reference text and clicking the left mouse button will take you to the relevant section. 

To return to the original page after viewing a cross-referred page in Adobe Acrobat or 
Adobe Reader, click on the “Previous View” arrow (  or ).
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1. Introduction

1.1 Abbreviations and Glossary

Contacts The name of the phonebook in a handset.

CSV file Comma Separated Value:
A file with data, where values in each row are 
separated by a delimiter, which can be a comma, a 
semicolon or a tab.

Device Can for example be a charger, desktop programmer, 
or a handset that is connected to WinPDM.

EAP Extensible Authentication Protocol

GUI Graphical User Interface.

JRE Sun Java Runtime Environment.

Language file Language file for handset or WinPDM.

License information file A file containing license keys for devices. The file can 
be exported from the License Web and imported to 
WinPDM.

License key The unique license key for a specific device with a 
specific functionality.

Number Settings for the complete set of parameters of a 
single device, tied to a specific identity.

Parameter definition file Defines the parameters for a device; for example a 
handset.

WinPDM Portable Device Manager.
An application, running on a computer, for 
management of devices.

Package file A file including different types of files, such as 
software files, parameter definition files or template 
files.

Prefix First set of digits/characters of a telephone number. 
For example country code, PBX specific codes etc.

Site Contains information of devices and Numbers.

Software file A file including software for a device.

Template General settings for a specific device. A template can 
be applied to several Numbers of the same device 
type.

USB Universal Serial Bus:
A serial bus standard to interface devices, for 
example connect computer peripherals such as 
mice, keyboards, scanners etc.

WiFi WiFi stands for Wireless Fidelity and is a term 
developed by the Wi-Fi Alliance® to describe 
wireless local area network (WLAN) products that are 
based on the Institute of Electrical and Electronics 
Engineers' (IEEE) 802.11 standards. Today, most 
people use WiFi as a reference to wireless 
connectivity.

VoIP Voice over Internet Protocol
17 September 2013 / Ver. PE1 1
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1.2 Requirements

See the Data Sheet for WinPDM.

1.3 WinPDM Description

1.3.1 WinPDM Terminology

This section gives a brief description of the basic terminology in WinPDM.

• Device; can be a charger, a desktop programmer or a handset that can be 
connected to WinPDM.

• Number; the complete settings for a single device.

• Template; general settings for a specific device type. A template can be applied to 
several Numbers of the same device type.

• License; licensed functionality for a device.

• Tabs; in the WinPDM there are four different tabs. In these tabs, the information for 
devices, Numbers, templates and licenses are shown.

• Parameter definition file; a file including all possible settings for a certain device 
type. Templates are created from parameter definition files.

• Software; is the software used in devices. The device software can be updated via 
WinPDM.

• Version; parameter definition files and device software are indicated by versions.

• Package file; a file that can contain other files, such as parameter definition files, 
software files and template files.

• Importing; different types of files can be imported.

• Associate; before being able to synchronize parameters between WinPDM and 
devices, it is necessary to associate a Number with the device. Association includes 
all parameters. If it exists on that device type, it also includes Contacts.

• Assign; it is possible to assign a Number to a device that has not yet been assigned 
a Number in the WinPDM. Assign includes only the parameters defining the 
Number.

VoWiFi Voice over Wireless Fidelity: a wireless version of 
VoIP and refers to IEEE 802.11a, 802.11b, 802.11g, 
and 802.11n network.
17 September 2013 / Ver. PE1 2
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2. Installation and Configuration of WinPDM

This section describes the basic settings required to getting started with the WinPDM. 
The basic settings and the sequence in which they should be completed are illustrated 
in figure 1.

Figure 1. Basic settings

2.1 Software Installation

NOTE: Do not connect any devices to the computer before installation.

1 Locate the software provided by your supplier. 

2 Double-click on the “Setup.exe” file located in the  WinPDM x.x.x folder, where 
x.x.x represents the software version of WinPDM.

3 Follow the instructions given by the Setup Wizard.

If an older version of WinPDM is installed, the setup wizard will uninstall the older 
version before installing the newer WinPDM version.

2.2 Software Configuration

2.2.1 Initial Startup

In Windows, select Start > All Programs > WinPDM > WinPDM.

NOTE: Windows Firewall may alert you of “PMServer” etc. You can ignore these 
security alerts, it will not affect the WinPDM, but then the alerts will appear every 
time the WinPDM is started. A better way is to select “Continue blocking” or 
“Unblock”.

The very first time the WinPDM is started, a Create site dialog appears.

Figure 2. Create site dialog.

1 In the Site name: field, enter a site name

2 In the Description: field, enter a description of the site (optional).

3 Click “OK”.

NOTE: Additional sites can also be created. See 4.4 Site Management on page 17.

Install WinPDM
software

Create site
(initial startup)
17 September 2013 / Ver. PE1 3
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3. Initial Configuration of Devices

This section applies to new devices that shall be configured the very first time. The 
devices are delivered with factory settings from the manufacturer. The initial settings 
and the sequence in which they should be completed are illustrated in figure 3.

Figure 3. Initial configuration of devices

3.1 Import Package Files 

The package files (.pkg) for your devices are distributed by your supplier. The package 
file includes the following:

• A software file (.bin) used for upgrading the device

• A parameter definition file (.def) including the parameters that can be configured in 
the device.

• Templates might also be included. The templates can for example include 
parameter settings for different exchange system.

NOTE: It is recommended to import the latest released package files for your devices.

1  In the File menu, select “File management”.

2 Click the “Parameter definition” tab and then click “Add”.

3 Select the package file (.pkg) to be imported and click “Open”.

4 Click “Close”.

3.2 Create Template with Common Settings

This section describes how to create a template including common settings that can be 
applied to the device’s numbers later on.

1 Click the “Templates” tab.

Create template
with common

settings

Import package
file for each
device type

Add numbers
and apply
template

Connect
device to 
computer

Associate 
number with 

device
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2 In the Template menu, select “New”. 

• Select which device type the template should be applicable for

• Select which parameter version the template should be based on. The 
parameter version determines which parameter settings that are available for 
your device type. It is recommended to select the latest parameter version to 
obtain full compatibly with the device. 

• Enter an appropriate name of the template

3 Click “OK”.

4 The Edit template dialog window opens showing the parameters organized in a 
tree structure in the left pane, with the parameters in the current node in the right 
pane. Clicking the  icon will give a short description of selected parameter. In 
addition, see also the manual for the device for more information about the 
parameter.

Select the parameters to be saved in the template by selecting the check box to 
the left o each parameter. Change the parameters to the desired values.

In the Edit template window, the following color coding is used:

5 When all needed parameters have been configured, click “OK” to save the 
settings.

Color Description

Black Normal

Dark blue Parameter has been edited during the current session

Purple The parameter is included in the template (checked)

Red Value not valid

Turquoise The value differs from the default value
17 September 2013 / Ver. PE1 5
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3.3 Create Numbers and Apply Template

This section describes how to create numbers to be associated with the devices later 
on. In addition, the common settings will also be applied to the numbers through the 
template you created earlier.

1 Click the “Numbers” tab.

2 In the Number menu, select “New...”. Alternatively, right-click in the Numbers list 
and select “New...”.

3 In the Device type drop-down list, select which device type the number(s) is 
created for.

4 In the Parameter version drop-down list, select the same parameter version 
used when you created the template for your device type.

5 In the Template drop-down list, select which template to be applied to the 
number(s). 

6 In the Prefix field, enter the prefix (if needed) to be added to the number(s).

7 Select one of the following options:

• To create a single number, select the "Single" option and enter the number.

• To create a range of numbers, select the "Range" option. Enter the start 
number and end number.
NOTE: The maximum range that can be added at a time is 100 numbers.

8 Click “OK”.

3.4 Connect Device to Computer

This section describes how to connect the devices to the computer running WinPDM.

 The device is connected to the computer running the WinPDM via the USB port. The 
device must be set up to handle this connection according to the instructions in the 
manual for the device.

Example of connected devices are shown in figure 4.

Figure 4. Connection to the computer running WinPDM
17 September 2013 / Ver. PE1 6
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Depending on connected device, a Device Wizard or a New Number Wizard might be 
shown. In this case, click “Do nothing” and then click “OK”.

Figure 5. The Device wizard

Figure 6. The New Number wizard

The device should now appear as online in WinPDM indicated by  in the Online 
column.

USB portWinPDM
17 September 2013 / Ver. PE1 7
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3.5 Associate Number with Device

This section describes how to configure the connected device with the number you 
created earlier and also to apply the common settings for the device.

1 Click the Numbers tab.

2 Select the device to be associated with a number.

3 In the Numbers menu, select “Associate with device...”.

4 Select the device to be configured with the selected number.

5 Click “OK”.

NOTE: If you cannot find your device in the list, the device is not compatible with the 
parameter version used when you created the number. In this case, the device’s 
software must first be updated and then you can associate the number with the 
device.

3.6 Upgrade a Device with New Software

This section describes how to upgrade the software in a device. To be able to associate 
a number with a device later on, the device’s parameter version must be compatible 
with the number’s parameter version. The compatible parameter version is applied to 
the device when upgrading the device’s software.

Additionally, newer software versions might be available since the device was delivered 
from the manufacturer, and it is therefore recommended to upgrade the device with the 
latest released software version.

1 Click the “Devices” tab.

2 Select the device to be upgraded.

3 In the Device menu, select “Upgrade software”. Alternatively, right-click the 
device in the list and select “Upgrade software”.

4 In the Available files: drop-down list, select the software to be uploaded.

5 Click “OK”.

The software will be downloaded to the device. A progress bar in the Status column for 
the device shows the progress of the download.
17 September 2013 / Ver. PE1 8
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To cancel the upgrade, right-click the device in the list and select “Cancel current 
upload”.

The device will restart automatically after a successful download.

6 When the device has been upgraded; the upgrade status shows Complete, the 
new software version, and the new parameter version for the device are also 
shown.

Figure 7. Example of completed software upgrade
17 September 2013 / Ver. PE1 9
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4. Operation

4.1 The WinPDM GUI

4.1.1 WinPDM Window

The WinPDM window consists of three areas: Menu, Toolbar and Work Area. The 
Toolbar has four tabs: Devices, Numbers, Templates and Licenses. When one of these 
tabs is selected the available device types are shown in the left hand pane of the work 
area. The right hand pane shows the devices, Numbers or templates that have already 
been configured.

 WinPDM Windows Overview

Search Field

In the upper part of the Work area there are search fields where different search criteria 
can be selected depending on which tab that is displayed. The search field is color 
coded green or red depending on if there are possible matches to the search criteria or 
not.

Sort the List

By default the lists are sorted by the first column. To sort the list by any other column, 
click the column heading. To reverse the sort order, click the column heading again. 
The sort order is indicated by an up or down arrow in the column heading.

Filter the List

By default the list in each tab shows all available Devices, Numbers or Templates. It is 
possible to filter the list by selecting a device type in left pane.

4.1.2 Color coding

General color coding

• If the version number is shown in red, WinPDM has found no parameter definition 
files supporting that device type.

• If the version number is shown in dark red, the parameter definition file is 
compatible, but does not have exactly the same version as the device.
17 September 2013 / Ver. PE1 10
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Color coding for parameter and template editing

In the parameter and template editing windows, the following color coding is used:

4.1.3 Tabs

Devices Tab

The view shows all devices configured at the site in a detailed list. The following 
information can be displayed (see also figure  on page 10):

• Description – optional information of a device that can be added by the WinPDM 
user. For example, the user of the device.

• Device ID – the unique identifier of the device.

• Device type – the device model.

• Software version – the version of the software in the device. 

• Parameter version – the version of the parameters in the Number

• Upgrade status – might show one of the following symbols:

• Online – shows if the device is connected to the computer running WinPDM. When 
connecting a device to the WinPDM, it might take a while before the device goes 
online. The  symbol indicates a device that has become connected/online.

• Latest number - shows the latest known Number for a device.

Numbers Tab

The view shows all Numbers configured at the site in a detailed list. The following 
information can be displayed:

• Description – optional information of a device that can be added by the WinPDM 
user. For example, the user of the number.

• Number – the unique identifier of the Number. The identifier is unique for that device 
type.

Color Context Description

Black General Normal

Dark blue For templates and parameter 
editing

Parameter has been edited during the 
current session

Purple For templates The parameter is included in the 
template (checked)

Red For templates and parameter 
editing

Value not valid

Turquoise For templates and parameter 
editing

The value differs from the default 
value

 – new software upgrade is in progress.
It is also possible to see a progress bar when the device is being 
upgraded.

 – software upgrade Pending, Request sent, or Accepted (a green 
arrow).

– Retrying

 – the last upgrade Failed or Aborted (a red broken arrow).
17 September 2013 / Ver. PE1 11
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• Device type – the device model the Number is intended for.

• Parameter version – shows the version of the parameters in the Number.

• Device ID – the unique identifier of the device that the Number is associated to.

• DECT Master - not used.

• Device Interface - not used.

• Online – shows if the device the Number is uploaded to is connected to the 
computer running WinPDM. It might take a while before a connected device goes 
online in the WinPDM. The  symbol indicates a device that is online/connected.

• Status – shows the parameter synchronization status. A Number can also be 
queued for synchronization. Several different indications are used, for example 
Synchronizing, Synchronized, etc. When the Number is offline, the status 
Synchronized or Not synched is shown.

• Saved – shows if the Number’s parameters have been stored in the database. The 
 symbol indicates that the parameters have been stored.

• Last login – shows the latest date and time the device was online in WinPDM/
logged in to WinPDM.

• Last run template - indicates which template that was last run for that Number.

 The Numbers tab in WinPDM

Templates Tab

The view shows all templates configured at the site in a detailed list. The following 
information can be displayed:

• Name – the name of the template.

• Device type – the device model.

• Parameter version – shows the parameter version.
17 September 2013 / Ver. PE1 12
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Figure 8. The Templates tab in WinPDM

 

Licenses Tab

NOTE: The License tab might not be applicable for all handsets.

The view shows all devices configured at the site in a detailed list. The following 
columns are displayed:

• Device ID – the unique identifier of the device.

• Device type – the device model.

• Online – shows if the device is connected to the Device Manager. The  symbol 
indicates that the device is online.

• Serial number – the number identifying the device hardware.

• Number – the unique identifier of the Number. The identifier is unique for that device 
type.

• Software version – shows the version of the software in the device

• Status – shows the license synchronization status.
Examples of status that can be shown are. 
"Sending" means that WinPDM is sending license information to the device.
"Server failure" means that there is some kind of error with the communication 
between WinPDM and the license server.
"Needs update" -  An attempt to move a license from one handset to another has 
been made, but the latest license does not exist in the handset.

In the bottom of the work area, the license options of the device are listed and whether 
the options are enabled or not. 

Figure 9. The Licenses tab in WinPDM
17 September 2013 / Ver. PE1 13
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4.1.4 Language Settings for WinPDM GUI

It is possible to select the language to be used in the menus in WinPDM by importing a 
language file with the file extension *.xml. 

The default language is english, and stored as a default translations file in your 
installation directory at installation:

C:\Program Files\ASAB\WinPDM\Client\default-translations.xml

This file can be copied and edited to create a new language and can then be imported 
as described below.

1 In the Options menu, select “Select language”.

2 Click the “Import...” button. In the Import files window, find and select the 
language file (.xml) to be imported and click “Open”.

3 In the Available languages: drop-down list, select which language to use.

4 Click “OK”.

TIP: For adding a new language to a device, see 4.9.6 Import Language Files for 
Devices on page 34 and 4.9.10 Delete Imported Files for Devices on page 35.
17 September 2013 / Ver. PE1 14
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4.2 The Device Wizard

When a device without a number is connected to the WinPDM, the Found Device 
Wizard window appears.

Figure 10. The Found Device Wizard Dialog

4.2.1 The New Number Wizard

When a new device with a not saved Number is connected, the New Number Wizard 
window appears.

Figure 11. The Found New Number Wizard Dialog

There are four choices in the New Number Wizard:

• Store in database

• Edit parameters, see also 4.5.5 Edit Parameters on page 21.

• Run template, see also 4.5.6 Run a Template to set Parameter Values on page 21.

• Do nothing
17 September 2013 / Ver. PE1 15



TD 92712EN
Installation and Operation Manual
Portable Device Manager (WinPDM) 4.  Operation
4.3 Open the WinPDM

1 In the Start menu, select All Programs >  WinPDM >  WinPDM.

2 The view of the last used Site opens. To open another site, see 4.4.2 Open a 
Site on page 17.
17 September 2013 / Ver. PE1 16
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4.4 Site Management

By creating a Site for each customer installation, devices, software and licenses can be 
managed for that site. The settings are saved in a database.

NOTE: There is a subtle but important difference between loading and opening a site. 
When a site is opened, the Site management dialog closes and it is possible to 
start working with the devices in the site. When a site is loaded, the Site 
management dialog stays open, making it possible to continue with site 
management tasks, such as creating and deleting sites.

Figure 12. Site Management Window

4.4.1 Create a New Site

1 In the File menu, select “Site management”.

2 Click “New...”.

3 Enter a name for the site and a description (optional) and click “OK”.

4 Click “Close”.

4.4.2 Open a Site

1 In the File menu, select “Site management”.

2 Select the site to be opened and click “Open”.

4.4.3 Load a Site

1 In the File menu, select “Site management”.

2 Select the site to be loaded.

3 Click “Load”. The view in the main window changes to the newly opened site.

4 Click “Close”.
17 September 2013 / Ver. PE1 17
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4.4.4 Delete a Site

1 In the File menu, select “Site management”.

2 Make sure that the site to be deleted is not currently active. If it is active, load 
another site (see 4.4.3 Load a Site).

If there is only one site remaining, it cannot be deleted.

3 Select the site to be deleted and click “Delete”.

4 In the Delete Site dialog, click “Yes”.

5 Click “Close”.

4.4.5 Import a Site

When importing a site, numbers with parameters and devices are imported. Templates, 
software and definition files are not imported.

1 In the File menu, select “Site Management”.

2 Click “Import...”.

3 Find and select the Site file (.ste) to be imported. Click “Open”.

4 In the Input dialog, enter a name for the site and click “OK”. 

5 Click “Close”

4.4.6 Export a Site

1 In the File menu, select “Site Management”.

2 Select the site to be exported and click “Export...”.

3 Enter a file name of the site (.ste) and where to save the file. Click “Save”.

4 Click “Close”

4.5 Numbers

4.5.1 Create New Numbers

1 Select the “Numbers” tab.

2 In the Number menu, select “New...”. Alternatively, right-click in the Numbers list 
and select “New...”.

3 In the Device type drop-down list, select device type.

4 In the Parameter version drop-down list, select the parameter version.

5 In the Template drop-down list, select which template to run on the Number. This 
is optional and therefore “None” can be selected.

6 In the Prefix field, enter the Number’s prefix (if needed).

7 Select one of the following options:

• To create a single Number, select the "Single" option and enter the call 
number. Click “OK”.

• To create a range of Numbers, select the "Range" option. Enter the start call 
number, end call number, and click “OK”.

NOTE: The maximum range that can be added at a time is 100 Numbers.
17 September 2013 / Ver. PE1 18
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4.5.2 Save a Number to Database

The number of an online device can be saved to the database.

1 In the Numbers tab, select the device which number to be saved.

2 In the Number menu, select "Save". Alternatively, right-click the device and 
select "Save".

4.5.3 Enter/Edit Description of a Number

1 It is possible to enter information of a Number using WinPDM. For example, the 
description can be used to describe a user of a number.

2 Select the “Numbers” tab.

3 Select the Number.

4 In the Number menu, select “Enter description”. Alternatively, right-click the 
Number and select “Enter description”.

5 Enter an appropriate description and click "OK" to save the setting.

4.5.4 Manage Certificate for a VoWiFi Handset

Certificates are used for authorizing a VoWiFi handset to access a WLAN system using 
the Extensible Authentication Protocol (EAP). 

There are two types of certificates: Root certificate and client certificate. 

The root certificate contains a public key and can be downloaded to the VoWiFi 
handset via WinPDM. The client certificate contains both a public key and a private key 
and can be downloaded to the VoWiFi handset via the WinPDM.

The VoWiFi handset uses the root certificate to check if the WLAN system is trusted. If 
the system is trusted, the handset sends the client certificate to show that it is 
authorized to access and log on to the system.

The following must be done to be able to use certificates:

• Import certificates to handset, see Import Certificates.

• Select which client certificate to be used by setting an EAP client certificate 
parameter, see the Configuration Manual for the VoWiFi handset.

Import Certificates

NOTE: Before proceeding, make sure that the handset is online ( ) in WinPDM. Both 
certificates will be stored in the handset.

1 Select the “Numbers” tab.

2 In the Number menu, select “Manage certificates”. Alternatively, right-click in the 
handset in the list and select “Manage certificates”.

Figure 13. Certificate dialog window
17 September 2013 / Ver. PE1 19
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In figure 13, the following information is displayed:

• The number of the device

• The device type

• The parameter version

• The online status of the device

• Imported certificates (if any)

3 Click the Root- or the Client certificate tab depending on which certificate to be 
managed.

4 Click “Browse“ and locate the certificate file to be imported.

5 If the certificate is protected, an Enter Password dialog opens. Enter the 
password and then click “OK”.

A Confirm Certificate window opens showing the details of the certificate.

6 Import the certificate to the device by clicking “Yes“.

If needed, repeat step 3 - 6 for editing additional certificates.

Additional settings are required for selecting which certificate the handset shall use. 
See Configuration Manual for the handset.

View Certificate Details

1 Select the “Numbers” tab.

2 In the Number menu, select “Manage certificates”. Alternatively, right-click the 
handset in the list and select “Manage certificates”.

3 Click the “Root” tab or the “Client” tab depending on which certificated to be 
viewed.

4 Select the certificate to view by clicking the corresponding “Details“ button.

A Certificate details window appears showing the details of the certificate.

Remove Certificate

1 Select the “Numbers” tab.

2 In the Number menu, select “Manage certificates”. Alternatively, right-click the 
handset in the list and select “Manage certificates”.
17 September 2013 / Ver. PE1 20



TD 92712EN
Installation and Operation Manual
Portable Device Manager (WinPDM) 4.  Operation
3 Click the “Root” tab or the “Client” tab depending on which certificated to be 
removed.

4 Select the certificate to be removed by clicking the corresponding “Remove“ 
button.

5 Click “Yes“ to confirm the deletion.

The certificates are now removed to the handset. Additional settings are required for 
selecting which certificate the handset shall use (if any). See the handset’s 
Configuration Manual.

4.5.5 Edit Parameters

The Edit Parameters dialog shows the set of parameters for the Device/Number. The 
parameters are organized in a tree structure in the left pane, with the parameters in the 
current node in the right pane. Clicking the  icon will give a short description of 
selected parameter.

NOTE: If Edit parameters was selected in the Device Wizard window, or in the New 
Number Wizard window, continue from step 4.

1 In the Numbers tab, select the device to be edited.

2 In the Number menu, select “Edit”. Alternatively, right-click and choose “Edit”, or 
double-click the device. 

3 In the left pane, select the parameters to be edited.

4 In the Value column, make your changes.

When a parameter has been edited, the node in the left pane changes to a blue color.

5 Click “OK” to save the changes, or click “Cancel” to undo all parameter changes. 
When saving the changes, the parameters are automatically sent to the device 
when it is online in WinPDM. 

4.5.6 Run a Template to set Parameter Values

If a template has been created for a device type, it can be used to set the parameter 
values for a range of devices, or a single device.

NOTE: If Run template was selected in the Device Wizard dialog window, or in the New 
Number Wizard dialog window, continue from step 4.

1 In the Numbers tab, select the device(s) you want to run the template on.
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2 In the Number menu, select “Run template...”. Alternatively, right-click the 
device(s) in the list and select “Run template...” from the menu that appears. 

3 In the Run template dialog window, select the template to be used and click 
“OK”.

4.5.7 Associate a Number with a Device

Before being able to synchronize parameters between WinPDM and devices, it is 
necessary to associate a Number with a device. It is possible to enter several Device 
IDs in advance and to associate them with a Number at a later moment.

NOTE: If Associate with number was selected in the Device Wizard window, continue 
from step 3.

1 Select the “Numbers” tab.

2 In the Number menu, select “Associate with device...”.

3 Select the device you want to associate with in the list and click “OK”.

If the selected device is online, it will immediately be updated with the selected 
Number. If the selected device is not online, it will be updated the next time it is online.

It is possible to associate several Numbers with several devices simultaneously.

4.5.8 Delete a Number in the Site Database

1 Select the “Numbers” tab.

2 Select the device which number you want to delete.

3 In the Number menu, select “Delete”. Alternatively, right-click the device in the 
list and select “Delete” from the menu that appears.

4 In the Delete Numbers dialog, click “Yes”.

NOTE: If a device that is online is deleted, it will stay in the list as online but not saved.

4.5.9 Rename a Number

1 In the Numbers tab, select the device which Number you want to rename.

2 In the Number menu, select "Rename...". Alternatively, right-click the device in 
the list and select “Rename...” from the menu that appears.

3 In the Rename number dialog, enter a new prefix (optional) and a new Number 
and click "OK".

4.5.10 Copy a Number

1 In the Numbers tab, select the device which Number you want to copy.

2 In the Number menu, select "Copy...". Alternatively, right-click the device in the 
list and select “Copy...” from the menu that appears.

3 In the Copy number dialog, enter a new prefix (optional) and a new Number and 
click "OK".

4.5.11 Import Contacts

NOTE: The number for the device must be saved, see 4.5.2 Save a Number to 
Database on page 19.
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Import Contacts From File

A file containing contacts can be imported to WinPDM and synchronized with a device. 
This can for example be useful when you want to transfer contacts from legacy devices 
to newer devices.

NOTE: When importing the file, the entries (if any) in the device will be replaced by the 
entries in the file. Additionally, the import works only if the receiving device can 
store all entries included in the file.

1 In the Numbers tab, select a number.

2 In the Number menu, select “Import contacts” > “From file”. Alternatively, right-
click the device and select “Import contacts”> “From file” from the menu that 
appears.

3 Find and select a file containing contacts. Click “Open”.

The contacts in the imported file are synchronized with the device.

Import Contacts From Number

You can make a copy of a device’s contact list and paste it to another device’s contact 
list directly. This means that you do not need to save the contact list temporarily on for 
example your computer.

NOTE: The import works only if the receiving device can store the entire contact list of 
the device you are importing from. Additionally, the Company phonebook 
contacts included in the Call contact list are not transferred to the other handset 
using this feature.

1 In the Numbers tab, select a number.

2 In the Number menu, select “Import contacts” > “From number”. Alternatively, 
right-click the Number in the Number list and select “Import contacts”> “From 
number” from the menu that appears.

3 Select a number.

4 Click “OK”.

The contacts are now imported to the handset.

4.5.12 Export Contacts to a File

It is possible to export contacts from a handset to a csv-file. The contacts can later on 
be transferred to another handset using the Import Contacts From File function (see  
Import Contacts From File on page 23). 

NOTE: When importing the file, the entries (if any) in the device will be replaced by the 
entries in the file. Additionally, the import works only if the receiving device can 
store all entries included in the file.

1 In the Numbers tab, select the desired handset whose contacts to be exported.

2 In the Number menu, select “Export contacts". Alternatively, right-click the 
handset and select “Export contacts" from the menu that appears. An Export 
contacts windows opens.

3 Enter a descriptive file name and press "Save".
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4.6 Devices

NOTE: This chapter is not applicable for the desktop programmer (DP1). Just connect 
the DP1 to the computer’s USB port and then put the VoWiFi handset in the 
programmer to get started. The DP1 will not appear as a device in the WinPDM. 

All work with devices is performed from the Devices tab.

• Devices can be added to a site by connecting the device to the computer.

• It is possible to transfer the information for a device to another device.

• Devices can be reset to factory settings.

• Devices can be updated with new software.

4.6.1 Add Devices to a Site

Before connecting a device to the WinPDM, make sure the connection is set up 
according to the instructions in the device’s manual (for example, Installation Guide or 
Configuration Manual).

If a range of new devices are to be added to a site, the easiest way is to: 

1 Create a template with all common parameter settings for the site. See 4.7.1 
Create a Parameter Template on page 26.

2 Add a range of Numbers and run the template. See 4.5.1 Create New Numbers 
on page 18 and 4.5.6 Run a Template to set Parameter Values on page 21.

3 Edit the parameters and change individual settings. See 4.5.5 Edit Parameters 
on page 21.

4 Connect the physical devices, one after the other, and associate them with the 
Numbers in the site database. See 4.5.7 Associate a Number with a Device on 
page 22.

A single device can be added in the same way.

4.6.2 Synchronize a Device

When a device is connected, it is synchronized with the associated Number in the 
WinPDM.

When a device is being synchronized, parameters that have been changed in the 
device are uploaded to the WinPDM, and parameters that have been changed in the 
WinPDM are sent to the device. If a parameter has been changed in both the device 
and the WinPDM, the setting made in the WinPDM will take precedence.

1 Select the “Numbers” tab.

2 Connect a device to the computer running the WinPDM. If the Number is saved, 
and it has a parameter definition, the device is automatically synchronized. 

4.6.3 Delete a Device in the Site Database

1 In the Devices tab, select the device to be deleted.

2 In the Device menu, select “Delete”, or right-click the device and select “Delete”.

3 In the Delete Device dialog, click “Yes”.

NOTE: It is not possible to delete a device that is online in WinPDM.
17 September 2013 / Ver. PE1 24



TD 92712EN
Installation and Operation Manual
Portable Device Manager (WinPDM) 4.  Operation
4.6.4 Replace a Device

If a device shall be replaced with a new device, it is possible to transfer its associated 
Number to a new device. The new device must be of the same device type as the old 
one.

1 If the device to be replaced is still working, make sure that it is synchronized.

2 Connect the new device to the WinPDM.

Associate the new device to the Number associated to the old device as follows: 

3 Select the “Numbers” tab.

4 In the Number menu, select “Associate with device...”.

5 Select the device you want to associate with in the list and click “OK”. The 
Number will no longer be associated to the old device.

4.6.5 Create New Device

It is possible to enter several new Device IDs in advance into WinPDM for later 
association.

In order to simplify input when handling many devices, it is possible to use a bar code 
reader. The bar code reader should send a carriage return after each item, but it is not 
necessary. If carriage return is not sent, it is necessary to click “Create” after each read 
item.

1 Select the “Devices” tab.

2 In the Device menu, select “Add device”.

3 Select device type and parameter version.

4 Enter a Device ID for the device, manually or by using a bar code reader.

5 The “Continuous registration” check box can be used to select whether the 
“Create devices” dialog shall close after clicking “Create” or if it shall still be 
open.

6 Click “Create”.

7 Repeat 4 to 6 if more devices are to be created, otherwise click "Close".

4.6.6 Assign a Number

It is possible to assign a Number to a device that has not yet been assigned a Number 
in WinPDM.

NOTE: Assign shall not be done on a device that already has a Number.

1 In the Devices tab, select the device that shall be assigned a Number.

2 In the Devices menu, select “Assign number”.

3 In the Assign number to device dialog, enter a new prefix (optional) and a new 
Number. Click “OK”.

4.6.7 Enter/Edit Description of a Device

1 It is possible to enter information of a device using WinPDM. For example, the 
description can be used to describe a location of a device.

2 Select the “Device” tab.

3 Select the device.
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4 In the Device menu, select “Enter description”. Alternatively, right-click the 
device and select “Enter description”.

5 Enter an appropriate description and click "OK" to save the setting.

4.6.8 Factory Reset

Factory reset means that the device parameters will be set to factory default settings. 
The Number in the database that is associated with the device will not be affected.

NOTE: The device must be online.

1 Select the “Devices” tab.

2 Select device(s) to be reset.

3 In the Device menu, click “Factory reset”. Alternatively, right-click the device and 
select “Factory reset”.

4 Click “Yes”.

4.6.9 Device Properties

To get a summary of the properties of a device:

1 Select the “Devices” tab.

2 Select device.

3 In the Device menu, click “Properties”. Alternatively, right-click the device and 
select “Properties”.

The following information is displayed (depending on WinPDM version):

• Description of the device (if entered by the WinPDM user)

• Device ID

• Device type

• Parameter version

• Software version

• Last known number

• Online status

• File upload information

4.7 Templates

Templates are a collection of user defined parameter values. These templates can be 
used to create common settings to be used on several devices of a certain device type.

NOTE: Templates created in one site are also selectable in the other sites used in 
WinPDM.

4.7.1 Create a Parameter Template

1 Select the “Templates” tab.

2 In the Template menu, select “New”. 

3 Select device type and parameter version, enter a name for the template, and 
click “OK”.
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NOTE: If the wanted device type and/or parameter version is not found in the list, 
WinPDM needs to be updated with new parameter definition files, see 4.9.3 
Import Parameter Definition Files on page 33.

4 In the Edit Template dialog window, select the parameters to be saved in the 
template by selecting the check box to the left of each parameter. Change the 
parameters to the desired values.

5 Click “OK”.

4.7.2 Create a Parameter Template from a Number

It is also possible to create a template from a device in the WinPDM. This can be used 
to save a device settings in the template that later on can be applied to other devices.

1 In the Numbers tab, right-click the device which settings to be used as template.

2 Select “Use as template...”.

3 Enter a name for the template.

4 Click “OK”. The Edit template dialog opens.

When creating a template based on a number, a Select drop-down list is shown in the 
bottom left corner. This setting decides which parameters that shall be copied from the 
device. If All parameters is selected, the synchronization time will be longer.

5 Select the parameters to be saved in the template by selecting the check box to 
the left of each parameter. Change the parameters to the desired values

It is also possible to create a template from a device that is online but not stored in the 
database. The template will contain all parameters for the device except for those that 
are Number specific.

4.7.3 Rename a Template

1 Select the "Templates" tab.

2 Select the template to be renamed.

3 In the Template menu, select "Rename...", or right-click and select "Rename...".

4 In the Rename template dialog, enter a new name and click “OK”.

4.7.4 Copy a Template

1 Select the "Templates" tab.

2 Select the template to be copied.

3 In the Template menu, select "Copy...", or right-click and select "Copy...".
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4 In the Copy template dialog, enter a new name and click “OK”.

4.7.5 Edit a Template

1 Select the "Templates" tab.

2 Select the template to be edited.

3 In the Template menu, select "Edit..." or right-click and select "Edit...".

4 In the Edit template window, edit the parameters and click “OK”.

4.7.6 Delete a template

1 Select the "Templates" tab.

2 Select the template to be deleted.

3 In the Template menu, select "Delete", or right-click and select "Delete", or press 
the Delete button.

4 In the Delete template dialog, click "Yes".

4.7.7 Upgrade a Template

NOTE: In order to upgrade a template, the new parameter version must have the same 
major version as the old parameter version. For example, upgrading from 25.8 to 
25.9 works, but upgrading from 25.8 to 26.x does not work.

1 Select the "Templates" tab

2 Select the template to be upgraded.

3 In the Template menu, select "Upgrade..." or right-click and select "Upgrade...".

4 Select the parameter version to upgrade to and click "OK".

4.7.8 Apply a Template

1 Select the "Templates" tab.

2 Select the template to be used.

3 In the Template menu, select "Apply to..." or right-click and select "Apply to...".

TIP: It is possible to search for a device in the list using the Search field in the Apply 
template... dialog window. 

4 Select device(s) to apply the template on and click "OK".
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4.8 Licenses

NOTE: This feature might not be applicable for all devices.

This section describes the device licensing features that can be done using the 
WinPDM. An overview of the device licensing concept is described in the Function 
Description for Product Licensing Overview documentation.

In WinPDM, device licensing offers a possibility to view, manage and upgrade licenses 
of devices. In the Licenses tab, devices are listed. If a device is selected in the list, the 
status of the license options for the selected device is displayed.

Note that some tasks include using the License Web and the details of how to work 
with the license web are not described here.

The following features are described:

• Upgrade licenses, "Import" and "Export"

• Manual synchronization of licensing information, "Refresh"

• View license options

• Filter license options

The following licensing features are not done with the WinPDM and are therefore not 
described is this document:

• How to work with the license web

• How to purchase licenses

• Manual license upgrade using handset

4.8.1 License Upgrade Alternatives

License upgrade includes using the license web which is described in the Function 
Description, Product Licensing Overview documentation.

These are the alternatives for upgrading licenses on devices:

• Automatic license upgrade
Used when the WinPDM has an Internet connection to the license server, see 4.8.2 
Automatic License Upgrade.

• License upgrade using export/import
Used when the WinPDM does not have an Internet connection, see 4.8.3 Export 
and Import Licensing Information.

• Manual license upgrade
Used to enter the license key manually in the device, see the manual for the 
corresponding device. In this case, the WinPDM is not used.

4.8.2 Automatic License Upgrade

NOTE: This feature requires an Internet connection.

The first time a device logs in to the WinPDM, it asks the license server if any licenses 
are available for the device. When the device logs in at a later time, there is no 
automatic check for licenses. If changes have been made, a manual upgrade must be 
done by selecting Refresh, see 4.8.6 Refresh on page 31.

Automatic license upgrade is a way of upgrading automatically to the correct license for 
a device. In order to get a purchased license for a device, a connection with the license 
server is made. The WinPDM automatically gets device licensing information from the 
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device, sends it to the license server which returns a license key that the WinPDM 
sends to the device. The device upgrades and the correct license information is shown 
in the WinPDM and the device.

4.8.3 Export and Import Licensing Information

In order to upgrade licenses on devices when the WinPDM does not have an internet 
connection to the license server, the following is done:

• The information needed for licensing of a device is exported from the WinPDM to a 
file, see Export Licensing Information on page 30.

• The file determines which additional license options that are available for the 
device. It can also be used to view the current license options of the device in the 
license web.

• From the license web, a license file containing the license keys for the device is 
generated

• The license file is imported to the WinPDM, see Import Licenses on page 30

• The WinPDM communicates the license key (included in the license file) to the 
device

• The device upgrades according to the license options

Export Licensing Information

The information needed for licensing of a device can be exported to a product 
information file. This file can be used to generate licenses for the device.

1 Select the Licenses tab.

2 Select the device(s) that shall be exported.

3 In the License menu, select "Export". Enter a name for the file and click "Save".

Import Licenses

License files are used for upgrading devices with licenses. A license file can be 
imported to the Device Manager.

1 In the File menu, select “Import” > "Licenses...”.

2 Select the license file(s) to be imported (*.xml) and click “Open”.

4.8.4 View License Options

It is possible to view which license options that exist on a device.

1 Select the License tab.

2 Select a device.

3 In the bottom of the work area, the license options of the device are listed and 
whether the options are enabled or not.

4.8.5 Filter License Options

It is possible to search and select devices which have same license options. The 
selected devices can be upgraded with additional licenses by exporting a product 
information file to the License Web (see Export Licensing Information on page 30). The 
advantage to select devices with same license options is that additional licenses can 
be applied for the devices simultaneously.

1 Select the License tab.
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2 Click “Advanced find“.

A License options filter dialog windows opens.

3 Under Device types, select device(s).

4 Under Option filters, select the status of the license option(s) that shall be 
common for the selected devices.

• Ignore - show all devices independent of license options.

• Enabled - show devices with a certain license option enabled.

• Disabled - show devices with a certain license option disabled.

The search result is updated directly when selecting devices and license options. In 
addition, the icon  is also displayed next to the Advanced find button to indicate that 
the search result is filtered.

When clicking Close, the filtered search result will still be displayed. When clicking 
Reset, the filter is removed and all devices are displayed.

4.8.6 Refresh

If a device is already registered in the WinPDM and a change of licenses has been 
done, the information needs to be updated. By doing a Refresh, the device license 
information in WinPDM is synchronized with the information in the license server and 
transferred to the device.

NOTE: This feature requires a connection to the license server.

1 Select the License tab.

2 Select device(s).

3 In the License menu, select "Refresh". The correct license is fetched from the 
license server, sent to the device and displayed in the Device Manager.

4.8.7 Remove Devices from the License View

This command removes devices from the licenses tab view.

1 Select the “Licenses” tab.

2 Select the devices(s) that shall be removed from the list. The selected row(s) are 
highlighted.
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3 In the License menu, select “Remove device”. Alternatively, right-click the device 
and select “Remove device”.

4 In the Remove device dialog, click “Yes”.

4.8.8 Move License

NOTE: This feature requires WinPDM that supports the move license feature, and a 
connection to the license server.

TIP: See also the device’s manual for more information on which device that support 
this feature.

If supported by the device, a license can be moved from one device to another device 
of the same device type. This feature can for example be used if your device is broken 
and you want to move the license to another device.

1 Select the “Licenses” tab.

2 Select the device whose license shall be moved. The selected row is highlighted.

3 In the License menu, select “Move license...” or right-click and select “Move 
license...”. The Move license window appears.

4 Select the device that shall receive the license. Click "OK".

If no devices are shown in the Move license window, there are no devices that 
are selectable to move the license to.

The device type of the device that received the license is still unchanged in the 
WinPDM. Select this device and do the following:

5 In the Licenses menu, select "Refresh" to complete the transfer of the license. 
The device type of the device is now updated in WinPDM.

4.9 File Management

This chapter covers File management for parameter definition files, software files, 
language files (.lng) for devices, and company phonebook files.

Import and export of templates and numbers are described in 4.10 Import and Export of 
Numbers and Templates on page 36. Import of language files (.xml) for the WinPDM 
menu are described in 4.1.4 Language Settings for WinPDM GUI on page 14.

The parameter definition file holds the definitions of all parameters for a specific version 
of a Number’s parameter set. Updated software and new parameter definition files for 
devices and Numbers can be added to the WinPDM, see 4.9.3 Import Parameter 
Definition Files on page 33.

Figure 14. The File Management Window
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4.9.1 Definition File Version – Parameter Version

Both definition files and device software include parameters and are indicated by a 
version number.

If a device associated to a Number is upgraded to a software supporting another 
parameter version than the stored Number, it does not always demand a new definition 
file. An old definition file can often be used, but if new parameters have been added in 
the new parameter version these parameters will not be editable. The release note will 
tell you if a new definition file is needed to match the new parameters. If the old 
definition file cannot be used, it will be highlighted with red. 

4.9.2 Import a Package File

A package file may include different types of files, such as software files, parameter 
definition files and/or template files. If the package does not include a certain file, it can 
be imported separately. See 4.9.3 Import Parameter Definition Files on page 33, 4.9.4 
Import New Software Files for Devices on page 34, and/or 4.10.3 Import Templates on 
page 36.

1 In the File menu, select “File management”.

2 Select the Parameter definition tab or Software tab and click “Add”.

3 Select the package file (.pkg) to be imported and click “Open”.

The files included in the package are now imported. If needed, select the "Parameter 
definition" tab or "Software" tab to view the corresponding imported files (if any). 

If template(s) has been imported, it can be viewed by clicking “Close“ and then 
selecting the "Template" tab.

4 Click “Close”.

4.9.3 Import Parameter Definition Files

TIP: Parameter definition files (.def) are mainly included in package files (.pkg) 
distributed by your supplier, see 4.9.2 Import a Package File on page 33.

1 In the File menu, select “File management”.

2 Select the Parameter definition tab and click “Add”.

3 Select the definition files to be imported and click “Open”.

Only files with a corresponding extension are shown, such as .def and .pkg.

4 Click “Close”.
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4.9.4 Import New Software Files for Devices

TIP: Software files (.bin) are mainly included in package files (.pkg) distributed by your 
supplier, see 4.9.2 Import a Package File on page 33.

1 In the File menu, select “File management”.

2 Select the Software tab and click “Add”.

3 Select the software files to be imported and click “Open”.

Only files with a corresponding extension are shown, such as .bin and .pkg.

4 Click “Close”.

5 To apply the software for a device, continue with the instruction in 4.9.5 Upgrade 
a Device with New Software.

4.9.5 Upgrade a Device with New Software

It is possible to upgrade the software in a device. The device must be online/logged in 
to WinPDM.

1 Select the “Devices” tab.

2 Select the device. It is possible to select several devices, but only devices of the 
same device type can be selected.

3 In the Device menu, select “Upgrade”.

Alternatively, right-click the device and choose “Upgrade”, double-click the 
desired device, or click the “Upgrade” button in the toolbar.

4 If needed; import the software file to be used by clicking “Import...”, locate the 
file, and click “OK”.

5 In the Available files: drop-down list, select the software to be uploaded.

6 Select software to be used and click “OK”.

The software will be downloaded to the device. A progress bar in the Status 
column for the device shows the progress of the download.

To cancel the upgrade, click Device > “Cancel upgrade” in the menu. 
Alternatively, right-click the device in the device list and select “Cancel upgrade”.

The device will restart automatically after a successful download.

4.9.6 Import Language Files for Devices

NOTE: To select the language to be used in the WinPDM, see 4.1.4 Language Settings 
for WinPDM GUI on page 14.

For adding a new language to a device, a language file (.lng) distributed by your 
supplier must be imported to the WinPDM and then uploaded to the device.

1 In the File menu, select “File management”.

2 Select the "Language" tab and click “Add”.

3 Select the language files to be imported and click “Open”.

Only files with a corresponding extension are shown, such as .lng.

4 Click "Close".

5 To apply the language for a device, continue with the instructions in 4.9.7 Upload 
a Language to Devices.
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4.9.7 Upload a Language to Devices

It is possible to upload a language to devices that support this feature.

1 In the Devices tab, select the device(s) to upload a language to. It is possible to 
select several devices, but only devices of the same device type can be 
selected.

2 In the Device menu, select "Upload Language...”.

3 If needed; import the language file (.lng) to be used by clicking “Import...”, locate 
the file, and click “OK”.

4 In the Available files: drop-down list, select which language to upload.

5 Click "OK".

4.9.8 Import Company Phonebook Files

It is possible to import a company phonebook file for later use. 

1 In the File menu, select “File management”.

2 Select the "Company Phonebook" tab and click “Add”.

3 Select the company phonebook files to be imported and click “Open”.

Only files with a corresponding extension are shown, such as .cpb.

4 Click “Close”

5 To upload the company phonebook to a device, continue with the instructions in 
4.9.9 Upload a Company Phonebook.

4.9.9 Upload a Company Phonebook

It is possible to upload the company phonebook to a device that supports this feature. 
The company phonebook will appear in the device’s Contacts list.

1 Select the “Devices” tab.

2 Select the device(s) to upload a company phonebook to. It is possible to select 
several devices, but only devices of the same device type can be selected.

3 In the Device menu, select "Upload company phonebook...”.

4 If needed; import the company phonebook file (.cpb) to be used by clicking 
“Import...”, locate the file, and click “OK”.

5 In the Available files: drop-down list, select which company phonebook to 
upload.

6 Click "OK".

4.9.10 Delete Imported Files for Devices

It is possible to delete parameter definition files, software files, language files (.lng) for 
devices, and company phonebook files.

It is possible to delete parameter definition files, software files, and language files (.lng) 
for devices.

1 In the File menu, select “File management”.

2 Select the applicable tab.

3 Select the file(s) to be deleted.

4 Click “Delete”.

5 In the Delete files dialog, click “Yes”.
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6 Click “Close”.

4.10 Import and Export of Numbers and Templates

This section describes import and export of Numbers and templates.

• Import and export of licensing information is described in 4.8 Licenses on page 29.

• Import and additional file handling of parameter definition files, software files, 
language files and company phonebook files for devices are described in 4.9 File 
Management on page 32.

• Import of language files for WinPDM are described in 4.1.4 Language Settings for 
WinPDM GUI on page 14.

The purpose of exporting and importing Numbers and templates is to be able to move 
Numbers and templates to another site or to use at a later time.

The parameter configuration in Numbers can be exported to a file. This file can be used 
by the supplier to pre-program devices before delivery to the customer, and to share 
Numbers and templates with other PDMs.

4.10.1 Import Numbers

Updated Number files may be distributed by your supplier.

1 In the File menu, select “Import” > “Numbers...”.

2 Select the Number files to be imported (*.xcp) and click “Open”.

If there is a Number conflict when importing Numbers, the error message Number 
import failed: Number already exists is displayed.

4.10.2 Export Numbers to a File

It is possible to configure Numbers for a site and export the settings to a file. One or 
several Numbers can be selected. The exported file can then be used when producing 
new devices for the customer. Only Numbers stored in the database can be exported. 
There is no restriction on device type when exporting.

1 Select the “Numbers” tab.

2 Select the Number(s).

3 In the Number menu, select “Export”.

4 Enter a file name for the Numbers (.xcp) and where to save the file and click 
“Save”.

4.10.3 Import Templates

Updated template files may be distributed by your supplier.

1 In the File menu, select “Import” > “Templates...”.

2 Select the template files to be imported (*.tpl) and click “Open”.

If there is a naming conflict when importing a template, the new template is imported 
and a digit within brackets is added after the name. The old template’s name is not 
affected.

For example:
Template MyHandset (old template)
Template MyHandset (2) (new template)
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4.10.4 Export Templates

It is possible to export template files. One or several templates can be exported.

1 Select the “Templates” tab. 

2 Select the template (or templates) to be exported.

3 In the Template menu, select “Export...”.

4 Enter a file name for the templates (.tpl) and where to save the file and click 
“Save”.
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5. Administration

5.1 Data Backup

All settings in the WinPDM, such as the configuration, the sites and the templates are 
stored as database files. It is recommended to do backups on a regular basis. Device 
software, definition files, templates, devices and Numbers including parameters are 
included in the backup.

5.1.1 Backup WinPDM Database Files

1 Close the WinPDM.

2 The database files are saved in the WinPDM folder located in:

Windows XP - C:\DOCUMENTS AND SETTINGS\<USER>\APPLICATION 
DATA\ASAB\

Windows 7 - C:\USERS\<USER>\APPDATA\ROAMING\ASAB\

3 Copy the WinPDM folder to, for example, a network drive.

5.1.2 Restore WinPDM Database Files

1 Close the WinPDM.

2 Retrieve the saved copy of the WinPDM folder.

3 Copy the WinPDM folder to:

Windows XP - C:\DOCUMENTS AND SETTINGS\<USER>\APPLICATION 
DATA\ASAB\

Windows 7 - C:\USERS\<USER>\APPDATA\ROAMING\ASAB\
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6. Uninstall the WinPDM

1 In the Windows Start menu, select your WinPDM application.

2 Select “Uninstall”. Follow the instructions in the Uninstall wizard. 
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7. Troubleshooting

When troubleshooting the WinPDM, it is always a good idea to examine the log files, 
since they provide additional information that may prove useful. When reporting an 
error to your supplier, always include the appropriate log file.

Log files are stored under

Windows XP - C:\DOCUMENTS AND SETTINGS\<USER>\APPLICATION 
DATA\ASAB\WinPDM\log

Windows 7 - C:\USERS\<USER>\APPDATA\ROAMING\ASAB\WinPDM\log

The log files are rotated every 10 MB and are time-stamped with 1 ms resolution.

Fault Action or comment

The WinPDM does not start or installation 
fails

To run the WinPDM, the computer 
must confirm to the requirements 
listed in 1.2 Requirements on page 2. 
If you do not have the correct 
software versions installed, contact 
your system administrator.

To install the WinPDM, you must 
have administrator rights on the 
computer. Contact your system 
administrator if you are not able to 
install the WinPDM.

Firewall alerts appear every time WinPDM 
is started.

Windows Firewall may alert you of 
“PMServer” etc. You can ignore these 
security alerts, it will not affect the 
WinPDM, but then the alerts will 
appear every time the WinPDM is 
started. A better way is to select 
“Continue blocking” or “Unblock”.
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Connected device does not appear in 
WinPDM.

Make sure the device is properly 
connected, or try disconnecting and 
reconnecting the device.

Make sure that the USB port is 
configured correctly as follows:

 - In Windows XP, open Windows 
Control Panel and select “System”. In 
the Hardware tab, select “Device 
Manager”.

- In Windows 7, open Windows 
Control Panel. Select System and 
Security > Hardware and Sound. 
Under Devices and Printers, select 
“Device Manager”.

If the device does not show up in the 
list (as an USB port controlled device 
depending on the handset model), 
check the connection and reinstall the 
drivers and/or software for the device.

A device’s software is not recognized/
synchronization fails

A device might have software with a 
parameter set that is newer than the 
version recognized by the WinPDM. 
The WinPDM will then be unable to 
send parameters to the device. 

The symbol  in the Parameters 
column for the selected device 
indicates that the synchronization 
between the device and the WinPDM 
was not successful. 
If this is the case, the WinPDM 
should be updated with new software 
and definition files provided by your 
local supplier. See 4.9.2 Import a 
Package File on page 33.

Upgrade of a device’s software fails 
(aborted)

The device does not support the 
software version. Use another 
software version. Ask your supplier.
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A Parameter conflict dialog window 
appears

If a device is detected and the same 
Number has been used by another 
device in the system there will be a 
parameter conflict. A dialog window 
appears, asking the user to decide 
whether to use the Number settings 
in WinPDM or the Number settings in 
the device.

One typical situation when this 
parameter conflict will occur is if a 
device’s hardware has been 
replaced. 

For example:
A replacement device has first been 
registered with the same Number as 
the damaged device. When the 
replacement device is connected to 
the WinPDM, the WinPDM will warn 
for a parameter conflict.

In this case, select “WinPDM” to 
transfer the phonebook of the 
damaged device (located in 
WinPDM) to the new device.

If “Device” is chosen in this situation, 
the phonebook belonging to the 
damaged device and located in 
WinPDM will be deleted (and 
replaced with the empty phonebook 
in the replacement device).

For more information about device 
replacement, see the User Manual or 
Configuration Manual for respective 
device.
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8. Related Documents

 

Data Sheet, Portable Device Manager (WinPDM), Windows Version

Configuration Manual for your handset

User Manual for your handset

Installation and Operation Manual/Installation Guide for your charger or desktop 
programmer
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9. Document History

For details in the latest version, see change bars in the document.

Version Date Description

A 17 November 2009 First release of document.

B 1 April 2011 In chapter 3.1.1 WinPDM Window > Sort the List;
"secondary sorting order..." removed.
Translation file replaced with Language file.
See change bars for more information.

C 28 October 2011 Chapter "Optional COM port settings" removed. 
"R232" removed in entire document. See changes 
bars for more information.

D 18 December 2012 Updated: 
1.2 Requirements on page 2: JRE 32-bit and JRE 
64-bit added.
 Numbers Tab on page 11: updated due to new 
columns

PE1 17 September 
2013

Added:
3. Initial Configuration of Devices on page 4
Updated:
4.5.11 Import Contacts on page 22: clarified the 
requirement of the receiving device.

Removed:
1.1.1 Installation and Configuration
1.1.2 Administration
1.2 Technical Solution
1.3.2 WinPDM Usage
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Appendix A: WinPDM Keyboard Shortcuts

A.1 General

A.2 Devices

A.3 Numbers

A.4 Templates

Shortcut Description

Ctrl + H Open the File management window.

Ctrl + Tab Switch tab

Alt + F4 Close the application

Shortcut Description

Ctrl + N Add a new device

Enter Upgrade the selected device(s)

Delete Delete the selected device(s)

Ctrl + F Find a device

Ctrl + Enter Open the Properties window for the selected device

Shortcut Description

Ctrl + N Add a new Number

Enter Edit the selected Number

Ctrl + C Copy the selected Number

F2 Rename the selected Number

Ctrl + S Save the selected Number to the database

Delete Delete the selected Number from the database

Ctrl + F Find a Number

Shortcut Description

Ctrl + N Add a new template

Enter Edit the selected template

Ctrl + C Copy the selected template

F2 Rename the selected template

Delete Delete the selected template

Ctrl + F Find a template
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A.5 Licenses

Shortcut Description

Delete Delete the selected license(s)

Ctrl + F Find a license
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Appendix B: File Types

In this appendix, the different file extensions that are used in WinPDM are explained. 
System files are not described.

File type Extension Description

Software file (devices) bin Software for devices

Company Phonebook file cpb Company Phonebook file for portable devices.

Parameter Definition file def Including all possible settings for a certain 
device type for a certain version.

Language file lng, or xml Language file for portable devices or WinPDM. 
Language file for WinPDM uses XML 
(eXtensible Markup Language.).

Package file pkg Archive that can include different file types such 
as parameter definition files (.def), software files 
(.bin) and template files (.tpl).

Site file ste Storage for site specific data. These files may 
not be edited manually.

Template file tpl Contains one or more exported templates.

Number file xcp Exported Numbers.

Product information file xml A file containing information needed for 
licensing and upgrade of a device.

License information file xml A file containing license keys for devices.
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